Goner Message Board
 | Forums | Register | Reply | Search | Statistics | Manual |
Goner Message Board / ???? / Help with Flash?
Posted: Jan 8, 2007 3:56 am | Edited by: Rachelandthecity
 
I am trying to embed this player and cannot figure out how to make it not autoplay

here's the script:

<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn .com/xspf/42689&autoload=1&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " />
<param name="quality" value="high" />
<embed src="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn.c om/xspf/42689&autoload=1&autoplay=true&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " quality="high" width="400" height="170" name="xspf_player" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object> <br><font face="sans-serif" size="2">get one at <a href="http://www.plurn.com/play/42689/?getplayer">Plurn.com</a>.</font >

I have tried:

autoplay=off

autoplay=false

I've tried with and without quotes...

and just taking it out of the script.

any ideas?
Posted: Jan 8, 2007 3:57 pm
 
i think you have to stop the flash from playing inside the .fla before you publish the .swf rather than trying to contol it from the html. i could be off here. is this a flash video or traditional flash movie?
Posted: Jan 8, 2007 4:06 pm
 
you have to add a parameter called "FlashVars" and put "autoPlay=false" in the data field.
Posted: Jan 8, 2007 4:21 pm
 
<embed FlashVars="autoPlay=true&initialTime=2171" src="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn.c om/xspf/42689&autoload=1&autoplay=true&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " quality="high" width="400" height="170" name="xspf_player"

is this what it would look like adding the bold txt? i didnt realise you were copying a link to an existing player at first. the player isnt working at all for me for some reason so i cant test it.
Posted: Jan 8, 2007 4:23 pm
 
Basically, get naked, put on a trenchcoat, go to the park or local college campus....
Posted: Jan 8, 2007 4:27 pm
 
oh and while naked, change it to this... DUH.

FlashVars="autoPlay=false"
Posted: Jan 8, 2007 4:28 pm
 
FlashVars="autoPlay=true&initialTime=2171

do I just paste this in?
Posted: Jan 8, 2007 4:31 pm
 
FlashVars="autoPlay=false"


ok, then where do I put it?

btw, thanks for your help.
Posted: Jan 8, 2007 4:32 pm
 
You're welcome. Boots are usually a nice touch, too.
Posted: Jan 8, 2007 4:33 pm
 
i screwed up and put the code to past in the start point of the video. you want yours to be the latter that says auto play false.

paste this=
FlashVars="autoPlay=false"

as it sits here... i think=
<embed FlashVars="autoPlay=false" src="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn.c om/xspf/42689&autoload=1&autoplay=true&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " quality="high" width="400" height="170" name="xspf_player"

try it anyway. like i said, i cant test it for some reason.
Posted: Jan 8, 2007 4:34 pm | Edited by: randyhobson
 
oh, and do this wearing pink boots... dont thank me yet.
Posted: Jan 8, 2007 4:37 pm
 
Posted: Jan 8, 2007 4:43 pm | Edited by: randyhobson
 
Posted: Jan 8, 2007 6:19 pm
 
that didn't work...

it's still autoplaying!

argh!
Posted: Jan 8, 2007 6:20 pm
 
here is the full script

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/sw flash.cab#version=7,0,0,0" width="400" height="170" id="xspf_player" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn .com/xspf/42689&autoload=1&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " />
<param name="quality" value="high" />
<embed src="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn.c om/xspf/42689&autoload=1&autoplay="off"&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " quality="high" bgcolor="818FC9" width="400" height="170" name="xspf_player" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></embed></object>
Posted: Jan 8, 2007 8:07 pm | Edited by: randyhobson
 
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/sw flash.cab#version=7,0,0,0" width="400" height="170" id="xspf_player" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn .com/xspf/42689&autoload=1&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " />
<param name="quality" value="high" />
<embed FlashVars="autoPlay=false" src="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn.c om/xspf/42689&autoload=1&autoplay="off"&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " quality="high" bgcolor="818FC9" width="400" height="170" name="xspf_player" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></embed></object>


putting the bold part of the string in there didnt help?
Posted: Jan 8, 2007 8:11 pm
 
you also have to add

<param name="FlashVars" value="autoPlay=false" />

somewhere within that object tag.
Posted: Jan 8, 2007 8:18 pm
 
<object classid="naked"
width="36" width="24" width="36"
param name="trenchcoat" value="open"></embed></object>

if location=college campus
select value
run
fast
Posted: Jan 8, 2007 8:20 pm
 
10 print "WOOOOOOOOOOOOOOOOOOO"
20 goto 10
Posted: Jan 8, 2007 8:22 pm
 
unzip tarballs
Posted: Jan 8, 2007 8:36 pm
 
alright this should do it:

<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/sw flash.cab#version=7,0,0,0" width="400" height="170" id="xspf_player" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn .com/xspf/42689&autoload=1&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " /> <param name="play" value="false" />
<param name="quality" value="high" />
<embed src="http://xml.plurn.com/playfull.swf?playlist_url=http://xml.plurn.c om/xspf/42689&autoload=1&autoplay="off"&player_title=PLURN PLAYER: The Shins - Wincing The Night Away " play="false" quality="high" bgcolor="818FC9" width="400" height="170" name="xspf_player" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" /></embed></object>


the stuff i added is in bold. the rest is exactly the same.
Posted: Jan 8, 2007 8:47 pm
 
I thought this thread was about Flash and the Board of Directors
Posted: Jan 9, 2007 6:09 pm
 
did this work?
Top
Your Reply Click this icon to move up to the quoted message
 

 
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

 
  Goner Message Board Powered by PHP Forum Software miniBB ®